成功最有效的方法就是向有经验的人学习!

思科交换机二层、三层Port-Channel配置

port-channel分为2类.一类为2层的port-channel.一类为3层的

2层的port-channel只需要配physical interface就行了,可以是static access,也可以使trunk,但是必须一样。不需要create port-channel。

3层的port-channel要首先create port-channel,然后no switchport把port-channel变成L3 interface,加上IP地址。再进入physical interface,必须no ip address去掉physical interface的IP信息,然后直接channel-group加入EtherChannel就行了。

为使port channel 正常工作,port channel 的成员端口必须具备以下相同的属性:
1 端口均为全双工模式;
2 端口速率相同;
3 端口的类型必须一样,比如同为以太口或同为光纤口;
4 端口同为access 端口并且属于同一个vlan 或同为trunk 端口;
5 如果端口为trunk 端口,则其allowed vlan 和native vlan 属性也应该相同。

example:
For L2 static access EtherChannel:

Switch# configure terminal 
Switch(config)# interface range gigabitethernet0/1 -2
Switch(config-if-range)# switchport mode access
Switch(config-if-range)# switchport access vlan 10
Switch(config-if-range)# channel-group 5 mode desirable
Switch(config-if-range)# end  

For L2 trunk EtherChannel:

Switch# configure terminal 
Switch(config)# interface range gigabitethernet0/1 -2 
Switch(config-if-range)# switchport trunk encapsulation isl 
Switch(config-if-range)# switchport mode trunk 
Switch(config-if-range)# channel-group 5 mode desirable 
Switch(config-if-range)# end  

For L3 EtherChannel:

Switch# configure terminal 
Switch(config)# interface port-channel 5 
Switch(config-if)# no switchport 
Switch(config-if)# ip address 172.10.20.10 255.255.255.0 
Switch(config-if)# interface range gigabitethernet0/1 -2 
Switch(config-if-range)# no ip address 
Switch(config-if-range)# channel-group 5 mode desirable
Switch(config-if-range)# end
赞(0) 打赏
未经允许不得转载:陈桂林博客 » 思科交换机二层、三层Port-Channel配置

大佬们的评论 1

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
  1. #1

    锐捷配置方法:
    SW1>enable
    SW1#configure terminal
    SW1(config)#interface range gigabitEthernet 0/1-3 ——>同时进入到g0/1-3口配置模式
    SW1(config-if-range)#port-group 1 ——>设置为AG1
    SW1(config-if-range)#exit
    SW1(config)#interface aggregateport 1 ——>进入AG1口配置模式
    SW1(config-if-AggregatePort 1)#switchport mode trunk ——>将AG1口配置为trunk口
    SW1(config-if-AggregatePort 1)#exit
    SW1(config)#aggregateport load-balance src-dst-ip ——>更改流量平衡算法为源目ip模式,默认为源MAC+目的MAC模式
    SW1(config)#exit
    SW1#wr

    admin3年前 (2019-09-09)回复

全新“一站式”建站,高质量、高售后的一条龙服务

橙子建站.极速智能建站8折购买虚拟主机

觉得文章有用就打赏一下文章作者

非常感谢你的打赏,我们将继续给力更多优质内容,让我们一起创建更加美好的网络世界!

支付宝扫一扫打赏

微信扫一扫打赏